正确简单地安装Tensorflow和Keras

安装前注意:

  • 这里只讨论tensorflow和keras的安装,如果你的电脑不支持CUDA、没有CUDA Toolkit、没有cuDNN这些基本的深度学习运算环境,那这篇文章可以关闭了。
  • 安装tensorflow和keras不要直接复制官网的任何命令,因为大部分情况下都会装错。
  • 安装一定要注意自己的cuda、python等环境的版本要对应,然后手动编写安装命令,不然全都错。

好的,为了切入重点,让我们开始安装。

[En]

All right, to get to the point, let’s start the installation.

1、Tensorflow安装

首先明确好自己的Python、cuda版本,比如我是:

Python Version: 3.6.13
CUDA Version: 10.0

关于如何检查版本的信息,请制作自己的百度。

[En]

For information about how to check the version, please make your own Baidu.

然后查询版本对照表:

linux/macOS版本对照表: https://www.tensorflow.org/install/source#gpu
windows版本对照表: https://www.tensorflow.org/install/source_windows#gpu

正确简单地安装Tensorflow和Keras

红色框中圈出的表示可以安装在您的环境中,其他版本的安装是错误的。

[En]

The representation circled in the red box can be installed in your environment, and the installation of other versions is wrong.

比如现在我想安装tensorflow2.0的GPU版本。那我就可以在命令行输入:

pip install tensorflow-gpu==2.0.0

或者:我想安装tensorflow2.0的CPU版本。那我就可以在命令行输入:

pip install tensorflow==2.0.0

最后回车即可。

注意!!!

  • 官网上说:tensorflow2 支持 CPU 和 GPU 的最新稳定版(适用于 Ubuntu 和 Windows),而对于 TensorFlow 1.x,CPU 和 GPU 软件包是分开的。这句话很有迷惑性,乍一看还以为是tensorflow2 把CPU 和 GPU 合并在一起了,其实不然,你要想使用gpu版本,还得在后面加个 -gpu
  • 如果pip命令拿不准可以去 https://pypi.org/ 搜索包的名字,搜索这个包及其历史版本的安装命令。如果是用conda: https://anaconda.org/anaconda/conda

2、Keras安装

keras安装之前需要TensorFlow、Theano、CNTK三个其中一个的环境,TensorFlow上面已经装好了,接下来只装keras即可。

和Tensorflow一样,安装Keras之前环境也必须对应,对照表如下:

  • keras对照表:https://docs.floydhub.com/guides/environments/(网站已经关闭了,可以看国内的一些博客,如下)
  • https://www.cnblogs.com/-yhwu/p/14619541.html(这篇博客很详细的搬运了keras环境对照表)
  • 也可以去github上看,不过不是很详细:https://github.com/keras-team/keras#release-and-compatibility

正确简单地安装Tensorflow和Keras

可以看到我只能安装 Keras 2.3.1的版本,安装其他的都会报错。命令如下:

pip install Keras==2.3.1

笔记

以下是一个与上述操作无关的扩展。

[En]

The following is an extension that has nothing to do with the above operation.

Tensorflow 和 Keras的关系?

tensorflow官网:https://www.tensorflow.org
keras官网:https://keras.io/

Keras 是一个模型级库,为开发深度学习模型提供了高层次的构建模块。它不处理诸如张量乘积和卷积等低级操作。相反,它依赖于一个专门的、优化的张量操作库来完成这个操作,它可以作为 Keras 的「后端引擎」。相比单独地选择一个张量库,而将 Keras 的实现与该库相关联,Keras 以模块方式处理这个问题,并且可以将几个不同的后端引擎无缝嵌入到 Keras 中。

目前,Keras 有三个后端实现可用: TensorFlow 后端, Theano 后端, CNTK 后端。而且如果安装了多个后端,是可以切换的,具体操作看官网。

什么是CUDA、CUDA Toolkit、cuDNN?

  • CUDA:为”GPU通用计算”构建的运算平台。
  • CUDA Toolkit (nvidia): CUDA完整的工具安装包,其中提供了 Nvidia 驱动程序、开发 CUDA 程序相关的开发工具包等可供安装的选项。包括 CUDA 程序的编译器、IDE、调试器等,CUDA 程序所对应的各式库文件以及它们的头文件。(NVCC 是CUDA的编译器,只是 CUDA Toolkit 中的一部分)
  • CUDA Toolkit (Pytorch): CUDA不完整的工具安装包,其主要包含在使用 CUDA 相关的功能时所依赖的动态链接库。不会安装驱动程序。
  • cuDNN:用于深度神经网络的GPU加速库,可以集成到更高级别的机器学习框架中,如tf、torch。

注意:CUDA 和 CUDA Toolkit 的版本是一致的。

可以这么理解:

  • CUDA 是一个工作台。
  • CUDA Toolkit 是一个工具箱,里面有扳手、螺丝刀等等,后面括号里表示在不同情况下所用的工具箱。
  • cuDNN 是一个工具,比如是个钳子。

如果是为了使用 PyTorch/TensorFlow,推荐使用 conda 安装CUDA Toolkit 和 cuDNN。即:

conda install cudatoolkit==版本号
conda install cudnn==版本号

安装 cudnn 时不加版本号会自动安装与 cudatoolkit 兼容的版本。

吐槽:tf不像torch那样很好装,torch官网直接提供了完整正确的安装命令生成器和完美的历史版本查询表。tf则没有,完全靠自己人肉对号入座,而且文档也写得一塌糊涂,链接引来引去,把重要的东西全写在后面了。

Original: https://blog.csdn.net/qq_38237214/article/details/122157197
Author: Jnchin
Title: 正确简单地安装Tensorflow和Keras

原创文章受到原创版权保护。转载请注明出处:https://www.johngo689.com/496396/

转载文章受原作者版权保护。转载请注明原作者出处!

(0)

大家都在看

亲爱的 Coder【最近整理,可免费获取】👉 最新必读书单  | 👏 面试题下载  | 🌎 免费的AI知识星球