pip安装ctypes、subprocess以及tensorflow-gpu2.4失败

(Window) ctypes、subprocess

ERROR: Could not find a version that satisfies the requirement ctypes(from versi ons: none )
EROR: No matching distribution found for ctypes

解决:

其实python自带ctypes和subprocess模块
检查一下python(import 不报错)。。。就会发现装不上,是因为不用装

pip安装ctypes、subprocess以及tensorflow-gpu2.4失败

; (Ubuntu) tensorflow-gpu2.4

说明没有对应的版本,或者只有1没有2。

[En]

It shows that there is no corresponding version or there is only 1 without 2.

Ubuntu检查python的版本,输入 python一般会提示没有,若提示python2的版本,卸载
Ubuntu查看Python版本,使用的是 Python3

完全卸载python2.7
sudo apt-get remove python2.7
sudo apt-get remove --auto-remove python2.7

pip安装,使用清华镜像源

pip install tensorflow-gpu-2.4.1 --upgrade -i https://pypi.tuna.tsinghua.edu.cn/simple some-package

Original: https://blog.csdn.net/weixin_43815873/article/details/123968234
Author: R$refresh
Title: pip安装ctypes、subprocess以及tensorflow-gpu2.4失败

原创文章受到原创版权保护。转载请注明出处:https://www.johngo689.com/496234/

转载文章受原作者版权保护。转载请注明原作者出处!

(0)

大家都在看

亲爱的 Coder【最近整理,可免费获取】👉 最新必读书单  | 👏 面试题下载  | 🌎 免费的AI知识星球