VUE-015-解决 vue install 引发的 failed Error: not found: python2 问题

好久没写 vue 相关的文章内容,此次文章标题问题起因是使用 npm 时,提示版本较低,建议升级,就盲从了一把,后面就是泪了,此处略过,不再细表,回归正题。

发生 install 异常时,提示信息如下所示:

从错误信息里看是 python 环境有问题,网上百度了一下都是重新安装配置 python2的环境或更换npm源,实际环境未进行变更,因而可以排除环境问题。

后来搜索到 node-sass 安装后,会自动执行 node-sass/scripts 下的 build.js,导致运行错误。

解决方法:

1、不重新安装配置 python 2

2、不更新 npm 安装源

3、进行 install 时不执行忽略构建脚本

4、若在 run dev 的时候,出现如下所示的错误

执行如下命令,重新编译构建一下 node-sass 即可。

Original: https://www.cnblogs.com/fengpingfan/p/16186355.html
Author: 范丰平
Title: VUE-015-解决 vue install 引发的 failed Error: not found: python2 问题

原创文章受到原创版权保护。转载请注明出处:https://www.johngo689.com/15817/

转载文章受原作者版权保护。转载请注明原作者出处!

(0)

大家都在看

发表回复

登录后才能评论
免费咨询
免费咨询
扫码关注
扫码关注
联系站长

站长Johngo!

大数据和算法重度研究者!

持续产出大数据、算法、LeetCode干货,以及业界好资源!

2022012703491714

微信来撩,免费咨询:xiaozhu_tec

分享本页
返回顶部